WakeMeOnLan

WakeMeOnLan v1.10
Copyright (c) 2011 Nir Sofer
Web site: http://www.nirsoft.net

Description

This utility allows you to easily turn on one or more computers remotely by sending Wake-on-LAN (WOL) packet to the remote computers.
When your computers are turned on, WakeMeOnLan allows you to scan your network, and collect the MAC addresses of all your computers, and save the computers list into a file. Later, when your computers are turned off or in standby mode, you can use the stored computers list to easily choose the computer you want to turn on, and then turn on all these computers with a single click.
WakeMeOnLan also allows you to turn on a computer from command-line, by specifying the computer name, IP address, or the MAC address of the remote network card.

System Requirements And Limitations

  • On the computer that you run WakeMeOnLan: WakeMeOnLan works on any version of Windows, starting from Windows 2000 and up to Windows 7/2008, including x64 versions of Windows.
  • On the remote computer: WakeMeOnLan can turn on the remote computer only if this feature is supported and enabled on the remote computer. Be aware that Wake-on-LAN feature only works on wired network. Wireless networks are not supported.
    In order to enable the Wake-on-LAN feature on the remote computer:
    • On some computers, you may need to enable this feature on the BIOS setup.
    • In the network card properties, you should go to the 'Power Management' and/or 'Advanced' tabs of the network adapter, and turn on the Wake-on-LAN feature.

Versions History

  • Version 1.10
    • Added 'Advanced Wake Up' (F7), which allows you to specify 2 advanced parameters for waking up your remote computers: Port Number and Broadcast Address.
    • Also, added the option to specify the port number and broadcast address from command-line.
  • Version 1.00 - First release.

Start Using WakeMeOnLan

WakeMeOnLan doesn't require any installation process or additional dll files. In order to start using it, simple run the executable file - WakeMeOnLan.exe
After running WakeMeOnLan, the first thing to do is to scan your network and collect the MAC addresses/computer names/IP addresses on your network. In order to start the network scan, simply press F5. If WakeMeOnLan scans the wrong IP addresses range, you can stop the scan process by pressing F6, and then go to the 'Advanced Options' window (F9), and choose the correct IP addresses range to scan.

All the computers information collected by WakeMeOnLan is saved into the configuration file (WakeMeOnLan.cfg) for loading it on the next time that you use WakeMeOnLan. You can also scan your network multiple times, and if there is a new computers on your network, it'll be added to the list. Scanning your network also updates the current status of every computer - 'on' (green icon) or 'off' (red icon). If there are obsolete computers on the list, you can remove them by using the 'Delete Selected Items' option.

Turn On Remote Computers On Your Network

After scanning your network in the first time, it's very easily to turn on the computers you need. Simply run WakeMeOnLan, select the desired computers, and then choose the 'Wake Up Selected Computer' option (F8).
After using the 'Wake Up Selected Computer' option, you can run another network scan, to verify that the computers are really turned on. Turned on computers are displayed with green icon.

Turn On a Computer From Command-Line

WakeMeOnLan allows you to wake up a computer on your network without displaying any user interface, by using the /wakeup command-line option. You can specify the computer name, IP address, or the free user text that you typed in the properties window, as long as the computer information is stored inside the .cfg file. You can also specify the MAC address of the remote network card, even if the computer is not stored in the .cfg file.

Optionally, you can specify the port number in the second parameter, and broadcast address in the third parameter.

Examples:
WakeMeOnLan.exe /wakeup 192.168.1.25
WakeMeOnLan.exe /wakeup Comp01
WakeMeOnLan.exe /wakeup Comp02
WakeMeOnLan.exe /wakeup 40-65-81-A7-16-23
WakeMeOnLan.exe /wakeup Comp02 30000 192.168.0.255
WakeMeOnLan.exe /wakeup 192.168.1.25 20000 192.168.1.255

Translating WakeMeOnLan to other languages

In order to translate WakeMeOnLan to other language, follow the instructions below:
  1. Run WakeMeOnLan with /savelangfile parameter:
    WakeMeOnLan.exe /savelangfile
    A file named WakeMeOnLan_lng.ini will be created in the folder of WakeMeOnLan utility.
  2. Open the created language file in Notepad or in any other text editor.
  3. Translate all string entries to the desired language. Optionally, you can also add your name and/or a link to your Web site. (TranslatorName and TranslatorURL values) If you add this information, it'll be used in the 'About' window.
  4. After you finish the translation, Run WakeMeOnLan, and all translated strings will be loaded from the language file.
    If you want to run WakeMeOnLan without the translation, simply rename the language file, or move it to another folder.

License

This utility is released as freeware. You are allowed to freely distribute this utility via floppy disk, CD-ROM, Internet, or in any other way, as long as you don't charge anything for this and you don't sell it or distribute it as a part of commercial product. If you distribute this utility, you must include all files in the distribution package, without any modification !

Disclaimer

The software is provided "AS IS" without any warranty, either expressed or implied, including, but not limited to, the implied warranties of merchantability and fitness for a particular purpose. The author will not be liable for any special, incidental, consequential or indirect damages due to loss of data or any other reason.

Feedback

If you have any problem, suggestion, comment, or you found a bug in my utility, you can send a message to nirsofer@yahoo.com